Описание
Уязвимость утилит pg_upgrade и pg_dump системы управления базами данных PostgreSQL связана с непринятием мер по защите структуры SQL-запроса. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольные SQL-команды
Вендор
Наименование ПО
Версия ПО
Тип ПО
Операционные системы и аппаратные платформы
Уровень опасности уязвимости
Возможные меры по устранению уязвимости
Статус уязвимости
Наличие эксплойта
Информация об устранении
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
- CVE
EPSS
9.8 Critical
CVSS3
7.5 High
CVSS2
Связанные уязвимости
ALT-PU-2018-2608: package `postgresql11` update to version 11.1-alt1
ALT-PU-2018-2607: package `postgresql10-1C` update to version 10.6-alt1
ALT-PU-2018-2606: package `postgresql10` update to version 10.6-alt1
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
EPSS
9.8 Critical
CVSS3
7.5 High
CVSS2