Описание
Уязвимость системы управления базами данных PostgreSQL связана с ошибками авторизации. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, повысить свои привилегии
Вендор
Наименование ПО
Версия ПО
Тип ПО
Операционные системы и аппаратные платформы
Уровень опасности уязвимости
Возможные меры по устранению уязвимости
Статус уязвимости
Наличие эксплойта
Информация об устранении
Идентификаторы других систем описаний уязвимостей
- CVE
EPSS
7.1 High
CVSS3
7.5 High
CVSS2
Связанные уязвимости
ALT-PU-2018-2136: package `postgresql10` update to version 10.5-alt1
ALT-PU-2018-2133: package `postgresql9.5` update to version 9.5.14-alt1
ALT-PU-2018-2132: package `postgresql9.6` update to version 9.6.10-alt1
ALT-PU-2018-2131: package `postgresql9.6-1C` update to version 9.6.10-alt1
It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statements involved with "INSERT ... ON CONFLICT DO UPDATE". An attacker with "CREATE TABLE" privileges could exploit this to read arbitrary bytes server memory. If the attacker also had certain "INSERT" and limited "UPDATE" privileges to a particular table, they could exploit this to update other columns in the same table.
EPSS
7.1 High
CVSS3
7.5 High
CVSS2