Описание
Уязвимость библиотеки libpq системы управления базами данных PostgreSQL связана с отсутствием обязательного использования TLS-соединения. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, реализовать атаку типа «человек посередине»
Вендор
Наименование ПО
Версия ПО
Тип ПО
Операционные системы и аппаратные платформы
Уровень опасности уязвимости
Возможные меры по устранению уязвимости
Статус уязвимости
Наличие эксплойта
Информация об устранении
Идентификаторы других систем описаний уязвимостей
- CVE
EPSS
5.9 Medium
CVSS3
5.4 Medium
CVSS2
Связанные уязвимости
ALT-PU-2017-3657: package `postgresql9.5` update to version 9.5.7-alt1
ALT-PU-2017-3641: package `postgresql9.6` update to version 9.6.3-alt1
ALT-PU-2017-3615: package `postgresql9.4` update to version 9.4.12-alt1
In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection to a PostgreSQL server. An active Man-in-the-Middle attacker could use this flaw to strip the SSL/TLS protection from a connection between a client and a server.
In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection to a PostgreSQL server. An active Man-in-the-Middle attacker could use this flaw to strip the SSL/TLS protection from a connection between a client and a server.
EPSS
5.9 Medium
CVSS3
5.4 Medium
CVSS2