Описание
Уязвимость системы управления базами данных PostgreSQL связана с ошибкой политики безопасности, в которой значения столбцов, которые имеют привилегию SELECT, могут быть прочитаны. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, получить доступ к конфиденциальным данным
Вендор
Наименование ПО
Версия ПО
Тип ПО
Операционные системы и аппаратные платформы
Уровень опасности уязвимости
Возможные меры по устранению уязвимости
Статус уязвимости
Наличие эксплойта
Информация об устранении
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
- CVE
EPSS
4.3 Medium
CVSS3
4 Medium
CVSS2
Связанные уязвимости
ALT-PU-2019-1788: package `postgresql10` update to version 10.8-alt1
ALT-PU-2019-1787: package `postgresql9.6` update to version 9.6.13-alt1
ALT-PU-2019-1786: package `postgresql9.5` update to version 9.5.17-alt1
ALT-PU-2019-1785: package `postgresql11` update to version 11.3-alt1
A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row-level security prunes the set of rows visible to the attacker.
EPSS
4.3 Medium
CVSS3
4 Medium
CVSS2