Описание
Уязвимость сервера приложений Apache Tomcat связана с неполной очисткой временных или вспомогательных ресурсов. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании путем отправки большого количества специально созданных HTTP-запросов
Вендор
Наименование ПО
Версия ПО
Тип ПО
Операционные системы и аппаратные платформы
Уровень опасности уязвимости
Возможные меры по устранению уязвимости
Статус уязвимости
Наличие эксплойта
Информация об устранении
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
- CVE
- ROS
EPSS
7.5 High
CVSS3
7.8 High
CVSS2
Связанные уязвимости
ALT-PU-2025-10912: package `tomcat10` update to version 10.1.20-alt2_jvm17.p10
ALT-PU-2025-10635: package `tomcat10` update to version 10.1.20-alt3.1_jvm17
ALT-PU-2025-10241: package `tomcat` update to version 9.0.102-alt2
ALT-PU-2025-8715: package `tomcat` update to version 9.0.98-alt0_1jpp17.p10.3
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
EPSS
7.5 High
CVSS3
7.8 High
CVSS2