Описание
Apache Tomcat has an Improper Authentication vulnerability
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.118, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.
Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Ссылки
- https://nvd.nist.gov/vuln/detail/CVE-2026-55955
- https://github.com/apache/tomcat/commit/3a9ff01d2dfaca651edacbda3260e37b98b540d3
- https://github.com/apache/tomcat/commit/5e594400c7f6ac0eaf2526bd64442a70f5ccaace
- https://github.com/apache/tomcat/commit/6a7a432cd7fb4ef358dc12e8da99cf3ab320f3fe
- https://lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106
- https://tomcat.apache.org/security-10.html
- https://tomcat.apache.org/security-11.html
- https://tomcat.apache.org/security-9.html
- http://www.openwall.com/lists/oss-security/2026/06/29/24
Пакеты
org.apache.tomcat:tomcat
>= 11.0.0-M1, < 11.0.23
11.0.23
org.apache.tomcat:tomcat
>= 10.1.0-M1, < 10.1.56
10.1.56
org.apache.tomcat:tomcat
>= 9.0.13, < 9.0.119
9.0.119
org.apache.tomcat:tomcat
>= 8.5.38, <= 8.5.100
Отсутствует
org.apache.tomcat:tomcat
>= 7.0.100, <= 7.0.109
Отсутствует
org.apache.tomcat:tomcat-tribes
>= 11.0.0-M1, < 11.0.23
11.0.23
org.apache.tomcat:tomcat-tribes
>= 10.1.0-M1, < 10.1.56
10.1.56
org.apache.tomcat:tomcat-tribes
>= 9.0.13, < 9.0.119
9.0.119
org.apache.tomcat:tomcat-tribes
>= 8.5.38, <= 8.5.100
Отсутствует
org.apache.tomcat:tomcat-tribes
>= 7.0.100, <= 7.0.109
Отсутствует
Связанные уязвимости
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Improper Authentication vulnerability in Apache Tomcat allowed a repla ...