Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

github логотип

GHSA-h3x4-894j-xpx5

Опубликовано: 26 авг. 2026
Источник: github
Github: Прошло ревью
CVSS3: 9.1

Описание

Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

Пакеты

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 11.0.0-M1, < 11.0.25

11.0.25

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 10.1.0-M1, < 10.1.58

10.1.58

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 9.0.0-M1, < 9.0.121

9.0.121

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 8.5.0, <= 8.5.100

Отсутствует

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 7.0.0, <= 7.0.109

Отсутствует

Наименование

org.apache.tomcat:tomcat-catalina

maven
Затронутые версииВерсия исправления

>= 11.0.0-M1, < 11.0.25

11.0.25

Наименование

org.apache.tomcat:tomcat-catalina

maven
Затронутые версииВерсия исправления

>= 10.1.0-M1, < 10.1.58

10.1.58

Наименование

org.apache.tomcat:tomcat-catalina

maven
Затронутые версииВерсия исправления

>= 9.0.0-M1, < 9.0.121

9.0.121

Наименование

org.apache.tomcat:tomcat-catalina

maven
Затронутые версииВерсия исправления

>= 8.5.0, <= 8.5.100

Отсутствует

Наименование

org.apache.tomcat:tomcat-catalina

maven
Затронутые версииВерсия исправления

>= 7.0.0, <= 7.0.109

Отсутствует

Наименование

org.apache.tomcat.embed:tomcat-embed-core

maven
Затронутые версииВерсия исправления

>= 11.0.0-M1, < 11.0.25

11.0.25

Наименование

org.apache.tomcat.embed:tomcat-embed-core

maven
Затронутые версииВерсия исправления

>= 10.1.0-M1, < 10.1.58

10.1.58

Наименование

org.apache.tomcat.embed:tomcat-embed-core

maven
Затронутые версииВерсия исправления

>= 9.0.0-M1, < 9.0.121

9.0.121

Наименование

org.apache.tomcat.embed:tomcat-embed-core

maven
Затронутые версииВерсия исправления

>= 8.5.0, <= 8.5.100

Отсутствует

Наименование

org.apache.tomcat.embed:tomcat-embed-core

maven
Затронутые версииВерсия исправления

>= 7.0.0, <= 7.0.109

Отсутствует

EPSS

Процентиль: 51%
0.00643
Низкий

9.1 Critical

CVSS3

Дефекты

CWE-863

Связанные уязвимости

CVSS3: 9.1
ubuntu
2 месяца назад

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

CVSS3: 6.5
redhat
2 месяца назад

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

CVSS3: 9.1
nvd
2 месяца назад

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

CVSS3: 9.1
debian
2 месяца назад

Incorrect Authorization vulnerability in Apache Tomcat's FORM authenti ...

CVSS3: 9.1
redos
около 2 месяцев назад

Уязвимость tomcat11

EPSS

Процентиль: 51%
0.00643
Низкий

9.1 Critical

CVSS3

Дефекты

CWE-863