Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

github логотип

GHSA-pg42-rg8c-j886

Опубликовано: 29 июн. 2026
Источник: github
Github: Прошло ревью
CVSS3: 6.1

Описание

Apache Tomcat has a Cross-site Scripting vulnerability

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Пакеты

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 11.0.0-M1, < 11.0.23

11.0.23

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 10.1.0-M1, < 10.1.56

10.1.56

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 9.0.0.M1, < 9.0.119

9.0.119

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

>= 8.5.0, <= 8.5.100

Отсутствует

Наименование

org.apache.tomcat:tomcat

maven
Затронутые версииВерсия исправления

<= 7.0.109

Отсутствует

EPSS

Процентиль: 91%
0.04091
Низкий

6.1 Medium

CVSS3

Дефекты

CWE-80

Связанные уязвимости

CVSS3: 6.1
ubuntu
4 месяца назад

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

CVSS3: 5.4
redhat
4 месяца назад

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

CVSS3: 6.1
nvd
4 месяца назад

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

CVSS3: 6.1
debian
4 месяца назад

Improper Neutralization of Script-Related HTML Tags in a Web Page (Bas ...

CVSS3: 6.1
redos
3 месяца назад

Уязвимость tomcat11

EPSS

Процентиль: 91%
0.04091
Низкий

6.1 Medium

CVSS3

Дефекты

CWE-80