Описание
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
A vulnerability was found in NGINX's module, ngx_http_mp4_module. This flaw allows a local attacker to corrupt NGINX worker memory, resulting in its termination using a specially crafted audio or video file. The issue affects only NGINX products built with ngx_http_mp4_module when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger the processing of a specially crafted audio or video file with ngx_http_mp4_module.
Отчет
For affected Red Hat products, the impact of this vulnerability is MODERATE. A local attacker with low privileges who can cause a specially crafted audio or video file to be processed by nginx's ngx_http_mp4_module, when the mp4 directive is configured, can corrupt NGINX worker memory, resulting in worker termination and potentially other impact. Current affects include Red Hat Enterprise Linux nginx streams, Red Hat Software Collections nginx streams, Red Hat Ansible Automation Platform, Ansible Services, Hosted OpenShift, cloud.redhat.com, Other Services, and Community Projects. The current affects also include delegated NOTAFFECTED records for Managed Application Services, one Red Hat Ansible Automation Platform record, and one Red Hat Enterprise Linux 9.7 record; these are outside the vulnerable configuration scope because exploitation requires both ngx_http_mp4_module and use of the mp4 directive. Red Hat and NIST assign CVSS 7.8 (CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H), while CVE.org records 7.0 with higher attack complexity; Red Hat's current impact remains MODERATE.
Меры по смягчению последствий
A mitigation for this vulnerability would be to disable the ngx_http_mp4_module module in your local Nginx environment.
Затронутые пакеты
| Платформа | Пакет | Состояние | Рекомендация | Релиз |
|---|---|---|---|---|
| Red Hat Ansible Automation Platform 1.2 | nginx | Affected | ||
| Red Hat Ansible Automation Platform 2 | nginx | Not affected | ||
| Red Hat Enterprise Linux 8 | nginx | Will not fix | ||
| Red Hat Enterprise Linux 8 | nginx:1.18/nginx | Will not fix | ||
| Red Hat Enterprise Linux 8 | nginx:1.20/nginx | Will not fix | ||
| Red Hat Software Collections | rh-nginx118-nginx | Will not fix | ||
| Red Hat Software Collections | rh-nginx120-nginx | Will not fix | ||
| Red Hat Enterprise Linux 9 | nginx | Fixed | RHSA-2025:7402 | 13.05.2025 |
| Red Hat Enterprise Linux 9.2 Extended Update Support | nginx | Fixed | RHSA-2025:7546 | 14.05.2025 |
| Red Hat Enterprise Linux 9.4 Extended Update Support | nginx | Fixed | RHSA-2025:7619 | 14.05.2025 |
Показывать по
Дополнительная информация
Статус:
EPSS
7.8 High
CVSS3
Связанные уязвимости
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source ...
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
EPSS
7.8 High
CVSS3