Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

redhat логотип

CVE-2026-14677

Опубликовано: 13 авг. 2026
Источник: redhat
CVSS3: 8.8
EPSS Низкий

Описание

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

A flaw was found in PostgreSQL. An integer wraparound vulnerability in 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This can lead to arbitrary code execution as the operating system user running the database.

Отчет

This Important vulnerability in PostgreSQL's 32-bit pltcl and plperl extensions allows an authenticated object creator to achieve arbitrary code execution as the database operating system user. The flaw stems from an integer wraparound, leading to out-of-bounds writes when processing crafted function bodies. Exploitation requires specific conditions related to 32-bit environments and the ability to create objects within the database.

Меры по смягчению последствий

To mitigate this issue, disable or remove the pltcl and plperl extensions if they are not essential for your PostgreSQL deployment, particularly in 32-bit environments. This can be done by revoking CREATE privilege on LANGUAGE pltcl and LANGUAGE plperl from untrusted users. If these extensions are necessary, ensure that only trusted users possess object creation privileges within the database.

Затронутые пакеты

ПлатформаПакетСостояниеРекомендацияРелиз
Red Hat Enterprise Linux 6postgresqlOut of support scope
Red Hat Hardened Imagespostgresql17Not affected
Red Hat Hardened Imagespostgresql18Not affected
Red Hat Enterprise Linux 10postgresql18FixedRHSA-2026:6728014.09.2026
Red Hat Enterprise Linux 10postgresql16FixedRHSA-2026:7018622.09.2026
Red Hat Enterprise Linux 10.0 Extended Update Supportpostgresql16FixedRHSA-2026:7228228.09.2026
Red Hat Enterprise Linux 7 Extended Lifecycle SupportpostgresqlFixedRHSA-2026:8458519.10.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6987622.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992322.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992423.09.2026

Показывать по

Дополнительная информация

Статус:

Important
Дефект:
CWE-190
https://bugzilla.redhat.com/show_bug.cgi?id=2515313postgresql: pltcl: plperl: PostgreSQL: Arbitrary code execution in 32-bit pltcl and plperl

EPSS

Процентиль: 36%
0.00414
Низкий

8.8 High

CVSS3

Связанные уязвимости

CVSS3: 8.8
ubuntu
3 месяца назад

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 8.8
nvd
3 месяца назад

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 8.8
msrc
3 месяца назад

PostgreSQL 32-bit pltcl and plperl undersize allocations, via integer wraparound

CVSS3: 8.8
debian
3 месяца назад

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl all ...

CVSS3: 8.8
github
3 месяца назад

Integer wraparound in PostgreSQL 32-bit builds of pltcl and plperl allows an object creator to cause the server to undersize an allocation and write out-of-bounds via crafted function bodies. This may execute arbitrary code as the operating system user running the database. CVE-2026-6473 had fixed similar problems. Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

EPSS

Процентиль: 36%
0.00414
Низкий

8.8 High

CVSS3