Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

redhat логотип

CVE-2026-15742

Опубликовано: 13 авг. 2026
Источник: redhat
CVSS3: 7.5
EPSS Низкий

Описание

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

A flaw was found in PostgreSQL fuzzystrmatch. A low-privileged database user can exploit an integer wraparound vulnerability by providing extreme inputs to the levenshtein() or levenshtein_less_equal() SQL functions. This allows the user to execute arbitrary code as the operating system user running the database, potentially leading to full system compromise.

Отчет

This vulnerability in the PostgreSQL fuzzystrmatch extension is rated as Important. A low-privileged database user could achieve arbitrary code execution as the operating system user running the database. This risk is present only when the fuzzystrmatch extension is explicitly installed and utilized, as it is not enabled by default in Red Hat deployments. The flaw stems from an integer wraparound when processing extreme inputs to specific SQL functions.

Меры по смягчению последствий

To mitigate this issue, consider disabling the fuzzystrmatch extension within PostgreSQL if its functionality is not essential. Alternatively, the postgresql-fuzzystrmatch package can be removed. Disabling or removing the extension may affect applications that rely on the levenshtein() or levenshtein_less_equal() functions. A database service restart may be required for these changes to take effect.

Затронутые пакеты

ПлатформаПакетСостояниеРекомендацияРелиз
Red Hat Enterprise Linux 6postgresqlOut of support scope
Red Hat Hardened Imagespostgresql17Not affected
Red Hat Hardened Imagespostgresql18Not affected
Red Hat Enterprise Linux 10postgresql18FixedRHSA-2026:6728014.09.2026
Red Hat Enterprise Linux 10postgresql16FixedRHSA-2026:7018622.09.2026
Red Hat Enterprise Linux 10.0 Extended Update Supportpostgresql16FixedRHSA-2026:7228228.09.2026
Red Hat Enterprise Linux 7 Extended Lifecycle SupportpostgresqlFixedRHSA-2026:8458519.10.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6987622.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992322.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992423.09.2026

Показывать по

Дополнительная информация

Статус:

Important
Дефект:
CWE-190
https://bugzilla.redhat.com/show_bug.cgi?id=2515314postgresql-fuzzystrmatch: PostgreSQL fuzzystrmatch: Arbitrary code execution via integer wraparound

EPSS

Процентиль: 49%
0.00595
Низкий

7.5 High

CVSS3

Связанные уязвимости

CVSS3: 8.8
ubuntu
3 месяца назад

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 8.8
nvd
3 месяца назад

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 8.8
msrc
3 месяца назад

PostgreSQL fuzzystrmatch writes effectively-arbitrary addresses, via integer wraparound

CVSS3: 8.8
debian
3 месяца назад

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct ...

CVSS3: 8.8
github
3 месяца назад

Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

EPSS

Процентиль: 49%
0.00595
Низкий

7.5 High

CVSS3