Описание
Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Older unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
A flaw was found in Apache Tomcat. The AJP secret was comparable in non-constant time, allowing an attacker on the local network to mount a timing attack to determine the AJP secret, which may lead to unauthorized access or other security bypasses.
Затронутые пакеты
| Платформа | Пакет | Состояние | Рекомендация | Релиз |
|---|---|---|---|---|
| Red Hat Certificate System 10 | redhat-pki:10/jss | Fix deferred | ||
| Red Hat Enterprise Linux 10 | tomcat | Under investigation | ||
| Red Hat Enterprise Linux 6 | tomcat6 | Under investigation | ||
| Red Hat Enterprise Linux 7 | tomcat | Under investigation | ||
| Red Hat Enterprise Linux 8 | pki-deps:10.6/pki-servlet-engine | Under investigation | ||
| Red Hat Enterprise Linux 9 | pki-servlet-engine | Under investigation | ||
| Red Hat Fuse 7 | tomcat-coyote | Out of support scope | ||
| Red Hat Hardened Images | hi/tomcat | Not affected | ||
| Red Hat JBoss Core Services | jbcs-httpd24-mod_cluster-native | Fix deferred | ||
| Red Hat JBoss Core Services | jbcs-httpd24-mod_proxy_cluster | Fix deferred |
Показывать по
Дополнительная информация
Статус:
EPSS
3.7 Low
CVSS3
Связанные уязвимости
Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
Observable Timing Discrepancy vulnerabilitywhen comparing AJP secret i ...
EPSS
3.7 Low
CVSS3