Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

redhat логотип

CVE-2026-43515

Опубликовано: 12 мая 2026
Источник: redhat
CVSS3: 5.4
EPSS Низкий

Описание

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

In Apache Tomcat, when multiple security constraints defined an HTTP method constraint for the same extension pattern, only the first method constraint was applied. A remote attacker could exploit this to bypass intended security restrictions for information or actions within the application.

Меры по смягчению последствий

Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

Затронутые пакеты

ПлатформаПакетСостояниеРекомендацияРелиз
Red Hat Certificate System 10redhat-pki:10/jssFix deferred
Red Hat Enterprise Linux 10jssWill not fix
Red Hat Enterprise Linux 10mod_proxy_clusterNot affected
Red Hat Enterprise Linux 6tomcat6Affected
Red Hat Enterprise Linux 7tomcatWill not fix
Red Hat Enterprise Linux 8pki-deps:10.6/pki-servlet-engineAffected
Red Hat Enterprise Linux 9jssWill not fix
Red Hat Enterprise Linux 9mod_proxy_clusterNot affected
Red Hat Enterprise Linux 9pki-servlet-engineAffected
Red Hat Fuse 7tomcat-coyoteWill not fix

Показывать по

Дополнительная информация

Статус:

Moderate
Дефект:
CWE-551
https://bugzilla.redhat.com/show_bug.cgi?id=2476519tomcat-coyote: tomcat: Improper Authorization allows security bypass

EPSS

Процентиль: 69%
0.01221
Низкий

5.4 Medium

CVSS3

Связанные уязвимости

CVSS3: 9.1
ubuntu
6 месяцев назад

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

CVSS3: 9.1
nvd
6 месяцев назад

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

CVSS3: 9.1
debian
6 месяцев назад

Improper Authorization vulnerability when multiple method constraints ...

CVSS3: 9.1
redos
5 месяцев назад

Уязвимость tomcat11

CVSS3: 9.1
redos
5 месяцев назад

Уязвимость tomcat10

EPSS

Процентиль: 69%
0.01221
Низкий

5.4 Medium

CVSS3