Описание
Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...})
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
A use-after-free flaw was found in the mod_rewrite module of Apache HTTP Server when evaluating URL lookahead expressions that reference HTTP request headers, such as %{LA-U:HTTP:...}. A remote attacker may be able to trigger invalid memory access in a server using an affected rewrite configuration, potentially causing a denial of service or arbitrary code execution.
Отчет
Red Hat initially assesses this issue as Important due to the potential for remote denial of service or code execution in affected mod_rewrite configurations. Exploitation requires URL lookahead expressions that reference HTTP request headers, such as %{LA-U:HTTP:...}. Product-specific impact and exploitation conditions remain under review with Engineering.
Меры по смягчению последствий
Review the effective Apache HTTP Server configuration, including virtual host configurations and .htaccess files, for affected HTTP-header lookahead expressions such as %{LA-U:HTTP:...}. Remove or replace these expressions where application requirements permit. Alternatively, disable mod_rewrite if the application does not require it. These changes may affect URL rewriting and application routing. Validate the configuration and reload or restart the service as appropriate. Apply a vendor-supported security update containing the fix when available.
Затронутые пакеты
| Платформа | Пакет | Состояние | Рекомендация | Релиз |
|---|---|---|---|---|
| Red Hat Enterprise Linux 10 | httpd | Affected | ||
| Red Hat Enterprise Linux 6 | httpd | Affected | ||
| Red Hat Enterprise Linux 7 | httpd | Affected | ||
| Red Hat Enterprise Linux 8 | httpd:2.4/httpd | Affected | ||
| Red Hat JBoss Core Services | jbcs-httpd24-httpd | Affected | ||
| Red Hat Enterprise Linux 9 | httpd | Fixed | RHSA-2026:88229 | 22.10.2026 |
| Red Hat Hardened Images | httpd-main-2.4.69-1.hum1 | Fixed | RHSA-2026:74858 | 02.10.2026 |
Показывать по
Дополнительная информация
Статус:
8.1 High
CVSS3
Связанные уязвимости
Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Apache HTTP Server: mod_rewrite use-after-free via %{LA-U:HTTP:...}
Use After Free vulnerability in Apache HTTP Server's mod_rewrite when ...
Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
8.1 High
CVSS3