Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

redhat логотип

CVE-2026-6471

Опубликовано: 13 авг. 2026
Источник: redhat
CVSS3: 7.2

Описание

Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

A flaw was found in PostgreSQL. Missing authorization in PostgreSQL's logical decoding feature allows a non-superuser with REPLICATION privilege to load arbitrary files. This can lead to arbitrary code execution as the operating system account running the server.

Отчет

Important: This flaw in PostgreSQL's logical decoding feature allows a non-superuser with the REPLICATION privilege to execute arbitrary code. Exploitation requires an attacker to already have significant access to the database, specifically the REPLICATION role, which is not granted by default to typical users, thus reducing the overall risk.

Меры по смягчению последствий

To mitigate this vulnerability, ensure that the REPLICATION privilege is granted only to highly trusted database superusers. Regularly review user privileges to confirm that non-superuser accounts do not possess the REPLICATION privilege unless absolutely necessary and their activities are closely monitored. If logical decoding is not actively used, consider disabling it to further reduce the attack surface, though specific configuration steps for disabling logical decoding are beyond the scope of this mitigation.

Затронутые пакеты

ПлатформаПакетСостояниеРекомендацияРелиз
Red Hat Enterprise Linux 6postgresqlNot affected
Red Hat Enterprise Linux 7postgresqlNot affected
Red Hat Hardened Imagespostgresql17Not affected
Red Hat Hardened Imagespostgresql18Not affected
Red Hat Enterprise Linux 10postgresql18FixedRHSA-2026:6728014.09.2026
Red Hat Enterprise Linux 10postgresql16FixedRHSA-2026:7018622.09.2026
Red Hat Enterprise Linux 10.0 Extended Update Supportpostgresql16FixedRHSA-2026:7228228.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6987622.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992322.09.2026
Red Hat Enterprise Linux 8postgresqlFixedRHSA-2026:6992423.09.2026

Показывать по

Дополнительная информация

Статус:

Important
Дефект:
CWE-94
https://bugzilla.redhat.com/show_bug.cgi?id=2515307postgresql: PostgreSQL: Arbitrary code execution via logical decoding plugin

7.2 High

CVSS3

Связанные уязвимости

CVSS3: 7.2
ubuntu
3 месяца назад

Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 7.2
nvd
3 месяца назад

Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

CVSS3: 7.2
msrc
3 месяца назад

PostgreSQL logical decoding can dlopen arbitrary file

CVSS3: 7.2
debian
3 месяца назад

Missing authorization in PostgreSQL logical decoding allows a non-supe ...

CVSS3: 7.2
github
3 месяца назад

Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.5, 17.11, 16.15, 15.19, and 14.24 are affected.

7.2 High

CVSS3