Описание
Security update for pgvector
This update for pgvector fixes the following issue:
- CVE-2026-103484: database users with the ability to create an IVFFlat index can write data out-of-bounds, which can lead to arbitrary code execution (bsc#1284129).
Changes for pgvector:
- Updated to version 0.8.7
Список пакетов
openSUSE Leap 16.0
pgvector-devel-0.8.7-160000.1.1
postgresql13-pgvector-0.8.7-160000.1.1
postgresql14-pgvector-0.8.7-160000.1.1
postgresql15-pgvector-0.8.7-160000.1.1
postgresql16-pgvector-0.8.7-160000.1.1
postgresql17-pgvector-0.8.7-160000.1.1
postgresql18-pgvector-0.8.7-160000.1.1
Ссылки
- SUSE Security Ratings
- SUSE Bug 1284129
- SUSE CVE CVE-2026-103484 page
Описание
IVFFlat index build in pgvector before 0.8.7 allows a database user to write data out-of-bounds, which can lead to arbitrary code execution.
Затронутые продукты
openSUSE Leap 16.0:pgvector-devel-0.8.7-160000.1.1
openSUSE Leap 16.0:postgresql13-pgvector-0.8.7-160000.1.1
openSUSE Leap 16.0:postgresql14-pgvector-0.8.7-160000.1.1
openSUSE Leap 16.0:postgresql15-pgvector-0.8.7-160000.1.1
Ссылки
- CVE-2026-103484
- SUSE Bug 1284129