Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

jQuery

jQuery — набор функций JavaScript, фокусирующийся на взаимодействии JavaScript и HTML.

Релизный цикл, информация об уязвимостях

Продукт: jQuery
Вендор: jquery

График релизов

12342006200720082009201020112012201320142015201620172018201920202021202220232024202520262027

Недавние уязвимости jQuery

Количество 85

github логотип

GHSA-q4m3-2j7h-f7xw

больше 6 лет назад

Cross-Site Scripting in jquery

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2020-7656

больше 6 лет назад

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 6.1
EPSS: Низкий
redhat логотип

CVE-2020-7656

больше 6 лет назад

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 5.4
EPSS: Низкий
debian логотип

CVE-2020-7656

больше 6 лет назад

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load ...

CVSS3: 6.1
EPSS: Низкий
ubuntu логотип

CVE-2020-7656

больше 6 лет назад

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2020-11023

больше 6 лет назад

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
EPSS: Высокий
nvd логотип

CVE-2020-11022

больше 6 лет назад

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
EPSS: Критический
redhat логотип

CVE-2020-11023

больше 6 лет назад

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
EPSS: Высокий
debian логотип

CVE-2020-11022

больше 6 лет назад

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from unt ...

CVSS3: 6.1
EPSS: Критический
debian логотип

CVE-2020-11023

больше 6 лет назад

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, pa ...

CVSS3: 6.1
EPSS: Высокий

Уязвимостей на страницу

Уязвимость
CVSS
EPSS
Опубликовано
1
github логотип
GHSA-q4m3-2j7h-f7xw

Cross-Site Scripting in jquery

CVSS3: 6.1
6%
Низкий
больше 6 лет назад
nvd логотип
CVE-2020-7656

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 6.1
6%
Низкий
больше 6 лет назад
redhat логотип
CVE-2020-7656

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 5.4
6%
Низкий
больше 6 лет назад
debian логотип
CVE-2020-7656

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load ...

CVSS3: 6.1
6%
Низкий
больше 6 лет назад
ubuntu логотип
CVE-2020-7656

jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

CVSS3: 6.1
6%
Низкий
больше 6 лет назад
nvd логотип
CVE-2020-11023

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
85%
Высокий
больше 6 лет назад
nvd логотип
CVE-2020-11022

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
99%
Критический
больше 6 лет назад
redhat логотип
CVE-2020-11023

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS3: 6.1
85%
Высокий
больше 6 лет назад
debian логотип
CVE-2020-11022

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from unt ...

CVSS3: 6.1
99%
Критический
больше 6 лет назад
debian логотип
CVE-2020-11023

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, pa ...

CVSS3: 6.1
85%
Высокий
больше 6 лет назад

Уязвимостей на страницу


Поделиться