Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

Node.js

Node.js — программная платформа, основанная на движке V8 (компилирующем JavaScript в машинный код)

Релизный цикл, информация об уязвимостях

Продукт: Node.js
Вендор: nodejs

График релизов

22232425262024202520262027202820292030

Релизные элементы

KBВерсияБилдДата доступности
24.22.224.22.2
24.22.124.22.1
24.22.024.22.0
24.21.024.21.0
24.20.024.20.0
24.19.024.19.0
24.18.124.18.1
24.18.024.18.0
24.17.024.17.0
24.16.024.16.0

Показывать по

Недавние уязвимости Node.js

Количество 1 296

redhat логотип

CVE-2017-3732

почти 10 лет назад

There is a carry propagating bug in the x86_64 Montgomery squaring procedure in OpenSSL 1.0.2 before 1.0.2k and 1.1.0 before 1.1.0d. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be very significant and likely only accessible to a limited number of attackers. An attacker would additionally need online access to an unpatched system using the target private key in a scenario with persistent DH parameters and a private key that is shared between multiple clients. For example this can occur by default in OpenSSL DHE based SSL/TLS ciphersuites. Note: This issue is very similar to CVE-2015-3193 but must be treated as a separate probl...

CVSS3: 5.9
EPSS: Средний
redhat логотип

CVE-2017-3731

почти 10 лет назад

If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.

CVSS3: 5.9
EPSS: Средний
nvd логотип

CVE-2013-7453

почти 10 лет назад

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via vectors related to UI redressing.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2013-7454

почти 10 лет назад

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via nested forbidden strings.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2013-7452

почти 10 лет назад

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2013-7451

почти 10 лет назад

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the XSS filter via a nested tag.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2014-9772

почти 10 лет назад

The validator package before 2.0.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via hex-encoded characters.

CVSS3: 6.1
EPSS: Низкий
nvd логотип

CVE-2015-8855

почти 10 лет назад

The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

CVSS3: 7.5
EPSS: Низкий
nvd логотип

CVE-2015-8860

почти 10 лет назад

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.

CVSS3: 7.5
EPSS: Низкий
debian логотип

CVE-2013-7454

почти 10 лет назад

The validator module before 1.1.0 for Node.js allows remote attackers ...

CVSS3: 6.1
EPSS: Низкий

Уязвимостей на страницу

Уязвимость
CVSS
EPSS
Опубликовано
1
redhat логотип
CVE-2017-3732

There is a carry propagating bug in the x86_64 Montgomery squaring procedure in OpenSSL 1.0.2 before 1.0.2k and 1.1.0 before 1.1.0d. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be very significant and likely only accessible to a limited number of attackers. An attacker would additionally need online access to an unpatched system using the target private key in a scenario with persistent DH parameters and a private key that is shared between multiple clients. For example this can occur by default in OpenSSL DHE based SSL/TLS ciphersuites. Note: This issue is very similar to CVE-2015-3193 but must be treated as a separate probl...

CVSS3: 5.9
15%
Средний
почти 10 лет назад
redhat логотип
CVE-2017-3731

If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.

CVSS3: 5.9
57%
Средний
почти 10 лет назад
nvd логотип
CVE-2013-7453

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via vectors related to UI redressing.

CVSS3: 6.1
2%
Низкий
почти 10 лет назад
nvd логотип
CVE-2013-7454

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via nested forbidden strings.

CVSS3: 6.1
2%
Низкий
почти 10 лет назад
nvd логотип
CVE-2013-7452

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.

CVSS3: 6.1
2%
Низкий
почти 10 лет назад
nvd логотип
CVE-2013-7451

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the XSS filter via a nested tag.

CVSS3: 6.1
2%
Низкий
почти 10 лет назад
nvd логотип
CVE-2014-9772

The validator package before 2.0.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via hex-encoded characters.

CVSS3: 6.1
3%
Низкий
почти 10 лет назад
nvd логотип
CVE-2015-8855

The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

CVSS3: 7.5
7%
Низкий
почти 10 лет назад
nvd логотип
CVE-2015-8860

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.

CVSS3: 7.5
4%
Низкий
почти 10 лет назад
debian логотип
CVE-2013-7454

The validator module before 1.1.0 for Node.js allows remote attackers ...

CVSS3: 6.1
2%
Низкий
почти 10 лет назад

Уязвимостей на страницу


Поделиться