Поиск уязвимостей
Количество 19
Количество 19
CVE-2024-39908
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.
CVE-2024-39908
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.
CVE-2024-39908
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.
CVE-2024-39908
CVE-2024-39908
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some ...
GHSA-4xqq-m2hx-25v8
REXML denial of service vulnerability
BDU:2024-08621
Уязвимость набора инструментов XML для Ruby REXML, связанная с неконтролируемым пот реблением ресурсов, позволяющая нарушителю вызвать отказ в обслуживании
ROS-20241021-01
Множественные уязвимости rubygem-rexml
RLSA-2024:6785
Moderate: ruby:3.3 security update
RLSA-2024:6784
Moderate: ruby:3.3 security update
ELSA-2024-6785
ELSA-2024-6785: ruby:3.3 security update (MODERATE)
ELSA-2024-6784
ELSA-2024-6784: ruby:3.3 security update (MODERATE)
SUSE-SU-2024:3874-1
Security update for ruby2.5
openSUSE-SU-2025:0129-1
Security update for rubygem-rexml
RLSA-2025:4488
Moderate: ruby:3.1 security update
RLSA-2025:4063
Moderate: ruby:3.1 security update
ELSA-2025-4488
ELSA-2025-4488: ruby:3.1 security update (MODERATE)
ELSA-2025-4063
ELSA-2025-4063: ruby:3.1 security update (MODERATE)
ALT-PU-2025-15265
ALT-PU-2025-15265: package `gem-rexml` update to version 3.4.4-alt1
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2024-39908 REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings. | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
CVE-2024-39908 REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings. | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
CVE-2024-39908 REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings. | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
CVSS3: 4.3 | 1% Низкий | около 2 лет назад | ||
CVE-2024-39908 REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some ... | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
GHSA-4xqq-m2hx-25v8 REXML denial of service vulnerability | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
BDU:2024-08621 Уязвимость набора инструментов XML для Ruby REXML, связанная с неконтролируемым пот реблением ресурсов, позволяющая нарушителю вызвать отказ в обслуживании | CVSS3: 4.3 | 1% Низкий | больше 2 лет назад | |
ROS-20241021-01 Множественные уязвимости rubygem-rexml | CVSS3: 5.3 | около 2 лет назад | ||
RLSA-2024:6785 Moderate: ruby:3.3 security update | около 2 лет назад | |||
RLSA-2024:6784 Moderate: ruby:3.3 security update | около 2 лет назад | |||
ELSA-2024-6785 ELSA-2024-6785: ruby:3.3 security update (MODERATE) | около 2 лет назад | |||
ELSA-2024-6784 ELSA-2024-6784: ruby:3.3 security update (MODERATE) | около 2 лет назад | |||
SUSE-SU-2024:3874-1 Security update for ruby2.5 | около 2 лет назад | |||
openSUSE-SU-2025:0129-1 Security update for rubygem-rexml | больше 1 года назад | |||
RLSA-2025:4488 Moderate: ruby:3.1 security update | больше 1 года назад | |||
RLSA-2025:4063 Moderate: ruby:3.1 security update | больше 1 года назад | |||
ELSA-2025-4488 ELSA-2025-4488: ruby:3.1 security update (MODERATE) | больше 1 года назад | |||
ELSA-2025-4063 ELSA-2025-4063: ruby:3.1 security update (MODERATE) | больше 1 года назад | |||
ALT-PU-2025-15265 ALT-PU-2025-15265: package `gem-rexml` update to version 3.4.4-alt1 | CVSS3: 7.5 | 11 месяцев назад |
Уязвимостей на страницу