Поиск уязвимостей
Количество 14
Количество 14
CVE-2017-9229
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.
CVE-2017-9229
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.
CVE-2017-9229
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.
CVE-2017-9229
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod i ...
GHSA-28pc-jv2f-hv8j
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.
openSUSE-SU-2017:3240-1
Security update for php7
SUSE-SU-2018:0003-1
Security update for php53
SUSE-SU-2017:3237-1
Security update for php7
openSUSE-SU-2017:3329-1
Security update for php5
SUSE-SU-2017:3277-1
Security update for php5
ALT-PU-2017-1820
ALT-PU-2017-1820: package `php5` update to version 5.6.31-alt1.S1
ALT-PU-2017-1855
ALT-PU-2017-1855: package `oniguruma` update to version 6.4.0-alt1.S1
ALT-PU-2017-1822
ALT-PU-2017-1822: package `php7` update to version 7.1.7-alt1.S1
SUSE-SU-2020:1570-1
Security update for ruby2.1
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2017-9229 An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition. | CVSS3: 7.5 | 5% Низкий | больше 9 лет назад | |
CVE-2017-9229 An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition. | CVSS3: 6.5 | 5% Низкий | больше 9 лет назад | |
CVE-2017-9229 An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition. | CVSS3: 7.5 | 5% Низкий | больше 9 лет назад | |
CVE-2017-9229 An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod i ... | CVSS3: 7.5 | 5% Низкий | больше 9 лет назад | |
GHSA-28pc-jv2f-hv8j An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition. | CVSS3: 7.5 | 5% Низкий | больше 4 лет назад | |
openSUSE-SU-2017:3240-1 Security update for php7 | почти 9 лет назад | |||
SUSE-SU-2018:0003-1 Security update for php53 | почти 9 лет назад | |||
SUSE-SU-2017:3237-1 Security update for php7 | почти 9 лет назад | |||
openSUSE-SU-2017:3329-1 Security update for php5 | почти 9 лет назад | |||
SUSE-SU-2017:3277-1 Security update for php5 | почти 9 лет назад | |||
ALT-PU-2017-1820 ALT-PU-2017-1820: package `php5` update to version 5.6.31-alt1.S1 | CVSS3: 9.8 | больше 9 лет назад | ||
ALT-PU-2017-1855 ALT-PU-2017-1855: package `oniguruma` update to version 6.4.0-alt1.S1 | CVSS3: 9.8 | больше 9 лет назад | ||
ALT-PU-2017-1822 ALT-PU-2017-1822: package `php7` update to version 7.1.7-alt1.S1 | CVSS3: 9.8 | больше 9 лет назад | ||
SUSE-SU-2020:1570-1 Security update for ruby2.1 | больше 6 лет назад |
Уязвимостей на страницу