Поиск уязвимостей
Количество 29
Количество 29
CVE-2022-31630
In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.
CVE-2022-31630
In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.
CVE-2022-31630
In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.
CVE-2022-31630
In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imagelo ...
GHSA-jw98-jrc9-mrx5
In PHP versions prior to 7.4.33, 8.0.25 and 8.2.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.
BDU:2022-07409
Уязвимость функции imageloadfont() интерпретатора языка программирования PHP, позволяющая нарушителю получить несанкционированный доступ к защищаемой информации или вызвать отказ в обслуживании
SUSE-SU-2022:4005-1
Security update for php8
ROS-20221222-04
Уязвимость PHP
ALT-PU-2022-7781
ALT-PU-2022-7781: package `php8.1-soap` update to version 8.1.12-alt1
ALT-PU-2022-7758
ALT-PU-2022-7758: package `php8.0-soap` update to version 8.0.25-alt1
ALT-PU-2022-7695
ALT-PU-2022-7695: package `php8.1-soap` update to version 8.1.12-alt1
ALT-PU-2022-7689
ALT-PU-2022-7689: package `php8.0-soap` update to version 8.0.25-alt1
ALT-PU-2022-3024
ALT-PU-2022-3024: package `php7` update to version 7.4.33-alt1
ALT-PU-2022-2994
ALT-PU-2022-2994: package `php7` update to version 7.4.33-alt1
ALT-PU-2022-2988
ALT-PU-2022-2988: package `php8.1` update to version 8.1.12-alt1
ALT-PU-2022-2986
ALT-PU-2022-2986: package `php8.0` update to version 8.0.25-alt1
ALT-PU-2022-2964
ALT-PU-2022-2964: package `php8.1` update to version 8.1.12-alt1
ALT-PU-2022-2960
ALT-PU-2022-2960: package `php8.0` update to version 8.0.25-alt1
RLSA-2023:2417
Moderate: php:8.1 security update
RLSA-2023:0965
Moderate: php security update
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2022-31630 In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information. | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
CVE-2022-31630 In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information. | CVSS3: 6.5 | 1% Низкий | около 4 лет назад | |
CVE-2022-31630 In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information. | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
CVE-2022-31630 In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imagelo ... | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
GHSA-jw98-jrc9-mrx5 In PHP versions prior to 7.4.33, 8.0.25 and 8.2.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information. | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
BDU:2022-07409 Уязвимость функции imageloadfont() интерпретатора языка программирования PHP, позволяющая нарушителю получить несанкционированный доступ к защищаемой информации или вызвать отказ в обслуживании | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
SUSE-SU-2022:4005-1 Security update for php8 | почти 4 года назад | |||
ROS-20221222-04 Уязвимость PHP | CVSS3: 7.1 | 1% Низкий | почти 4 года назад | |
ALT-PU-2022-7781 ALT-PU-2022-7781: package `php8.1-soap` update to version 8.1.12-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-7758 ALT-PU-2022-7758: package `php8.0-soap` update to version 8.0.25-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-7695 ALT-PU-2022-7695: package `php8.1-soap` update to version 8.1.12-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-7689 ALT-PU-2022-7689: package `php8.0-soap` update to version 8.0.25-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-3024 ALT-PU-2022-3024: package `php7` update to version 7.4.33-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-2994 ALT-PU-2022-2994: package `php7` update to version 7.4.33-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-2988 ALT-PU-2022-2988: package `php8.1` update to version 8.1.12-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-2986 ALT-PU-2022-2986: package `php8.0` update to version 8.0.25-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-2964 ALT-PU-2022-2964: package `php8.1` update to version 8.1.12-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
ALT-PU-2022-2960 ALT-PU-2022-2960: package `php8.0` update to version 8.0.25-alt1 | CVSS3: 9.8 | около 4 лет назад | ||
RLSA-2023:2417 Moderate: php:8.1 security update | 11 месяцев назад | |||
RLSA-2023:0965 Moderate: php security update | больше 3 лет назад |
Уязвимостей на страницу