Поиск уязвимостей
Количество 13
Количество 13
CVE-2024-4068
The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
CVE-2024-4068
The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
CVE-2024-4068
The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
CVE-2024-4068
Memory Exhaustion in braces
CVE-2024-4068
The NPM package `braces`, versions prior to 3.0.3, fails to limit the ...
GHSA-grv7-fg5c-xmjg
Uncontrolled resource consumption in braces
BDU:2024-09427
Уязвимость библиотеки braces, связанная с неконтролируемым потреблением ресурсов, позволяющая нарушителю вызвать отказ в обслуживании
SUSE-SU-2025:1326-1
Security update for pgadmin4
SUSE-SU-2025:01326-1
Security update for pgadmin4
SUSE-SU-2024:3771-1
Security update for pgadmin4
ALT-PU-2025-9551
ALT-PU-2025-9551: package `opensearch` update to version 3.1.0-alt3
ALT-PU-2025-9506
ALT-PU-2025-9506: package `opensearch` update to version 3.1.0-alt3
ROS-20241029-08
Множественные уязвимости opensearch
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2024-4068 The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash. | CVSS3: 7.5 | 1% Низкий | больше 2 лет назад | |
CVE-2024-4068 The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash. | CVSS3: 7.5 | 1% Низкий | больше 2 лет назад | |
CVE-2024-4068 The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash. | CVSS3: 7.5 | 1% Низкий | больше 2 лет назад | |
CVE-2024-4068 Memory Exhaustion in braces | CVSS3: 7.5 | 1% Низкий | 3 месяца назад | |
CVE-2024-4068 The NPM package `braces`, versions prior to 3.0.3, fails to limit the ... | CVSS3: 7.5 | 1% Низкий | больше 2 лет назад | |
GHSA-grv7-fg5c-xmjg Uncontrolled resource consumption in braces | CVSS3: 7.5 | 1% Низкий | больше 2 лет назад | |
BDU:2024-09427 Уязвимость библиотеки braces, связанная с неконтролируемым потреблением ресурсов, позволяющая нарушителю вызвать отказ в обслуживании | CVSS3: 7.5 | 1% Низкий | почти 3 года назад | |
SUSE-SU-2025:1326-1 Security update for pgadmin4 | больше 1 года назад | |||
SUSE-SU-2025:01326-1 Security update for pgadmin4 | около 1 года назад | |||
SUSE-SU-2024:3771-1 Security update for pgadmin4 | около 2 лет назад | |||
ALT-PU-2025-9551 ALT-PU-2025-9551: package `opensearch` update to version 3.1.0-alt3 | CVSS3: 7.5 | больше 1 года назад | ||
ALT-PU-2025-9506 ALT-PU-2025-9506: package `opensearch` update to version 3.1.0-alt3 | CVSS3: 7.5 | больше 1 года назад | ||
ROS-20241029-08 Множественные уязвимости opensearch | CVSS3: 7.5 | около 2 лет назад |
Уязвимостей на страницу