Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

Поиск уязвимостей

Количество 12

Количество 12

ubuntu логотип

CVE-2025-5889

больше 1 года назад

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
EPSS: Низкий
redhat логотип

CVE-2025-5889

больше 1 года назад

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
EPSS: Низкий
nvd логотип

CVE-2025-5889

больше 1 года назад

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
EPSS: Низкий
msrc логотип

CVE-2025-5889

около 1 года назад

juliangruber brace-expansion index.js expand redos

CVSS3: 3.1
EPSS: Низкий
debian логотип

CVE-2025-5889

больше 1 года назад

A vulnerability was found in juliangruber brace-expansion up to 1.1.11 ...

CVSS3: 3.1
EPSS: Низкий
github логотип

GHSA-v6h2-p8h4-qcjw

больше 1 года назад

brace-expansion Regular Expression Denial of Service vulnerability

CVSS3: 3.1
EPSS: Низкий
fstec логотип

BDU:2026-01715

больше 1 года назад

Уязвимость функции expand() библиотеки juliangruber/brace-expansion программной платформы Node.js, позволяющая нарушителю вызвать отказ в обслуживании

CVSS3: 3.1
EPSS: Низкий
suse-cvrf логотип

openSUSE-SU-2026:20998-1

5 месяцев назад

Security update for tree-sitter-ruby

EPSS: Низкий
redos логотип

ROS-20260327-80-0003

8 месяцев назад

Уязвимость nodejs22

CVSS3: 3.1
EPSS: Низкий
redos логотип

ROS-20260327-73-0003

8 месяцев назад

Уязвимость nodejs

CVSS3: 3.1
EPSS: Низкий
altlinux логотип

ALT-PU-2026-17292

около 1 месяца назад

ALT-PU-2026-17292: package `npm` update to version 8.19.3-alt3

CVSS3: 7.5
EPSS: Низкий
suse-cvrf логотип

SUSE-SU-2025:3744-1

около 1 года назад

Security update for aws-cli, local-npm-registry, python-boto3, python-botocore, python-coverage, python-flaky, python-pluggy, python-pytest, python-pytest-cov, python-pytest-html, python-pytest-metadata, python-pytest-mock

EPSS: Низкий

Уязвимостей на страницу

Уязвимость
CVSS
EPSS
Опубликовано
ubuntu логотип
CVE-2025-5889

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
1%
Низкий
больше 1 года назад
redhat логотип
CVE-2025-5889

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
1%
Низкий
больше 1 года назад
nvd логотип
CVE-2025-5889

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

CVSS3: 3.1
1%
Низкий
больше 1 года назад
msrc логотип
CVE-2025-5889

juliangruber brace-expansion index.js expand redos

CVSS3: 3.1
1%
Низкий
около 1 года назад
debian логотип
CVE-2025-5889

A vulnerability was found in juliangruber brace-expansion up to 1.1.11 ...

CVSS3: 3.1
1%
Низкий
больше 1 года назад
github логотип
GHSA-v6h2-p8h4-qcjw

brace-expansion Regular Expression Denial of Service vulnerability

CVSS3: 3.1
1%
Низкий
больше 1 года назад
fstec логотип
BDU:2026-01715

Уязвимость функции expand() библиотеки juliangruber/brace-expansion программной платформы Node.js, позволяющая нарушителю вызвать отказ в обслуживании

CVSS3: 3.1
1%
Низкий
больше 1 года назад
suse-cvrf логотип
openSUSE-SU-2026:20998-1

Security update for tree-sitter-ruby

5 месяцев назад
redos логотип
ROS-20260327-80-0003

Уязвимость nodejs22

CVSS3: 3.1
1%
Низкий
8 месяцев назад
redos логотип
ROS-20260327-73-0003

Уязвимость nodejs

CVSS3: 3.1
1%
Низкий
8 месяцев назад
altlinux логотип
ALT-PU-2026-17292

ALT-PU-2026-17292: package `npm` update to version 8.19.3-alt3

CVSS3: 7.5
около 1 месяца назад
suse-cvrf логотип
SUSE-SU-2025:3744-1

Security update for aws-cli, local-npm-registry, python-boto3, python-botocore, python-coverage, python-flaky, python-pluggy, python-pytest, python-pytest-cov, python-pytest-html, python-pytest-metadata, python-pytest-mock

около 1 года назад

Уязвимостей на страницу