Поиск уязвимостей
Количество 22
Количество 22
CVE-2021-21705
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
CVE-2021-21705
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
CVE-2021-21705
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
CVE-2021-21705
Incorrect URL validation in FILTER_VALIDATE_URL
CVE-2021-21705
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below ...
openSUSE-SU-2021:2575-1
Security update for php7
SUSE-SU-2021:2564-1
Security update for php72
GHSA-rxcr-7xjm-f9c9
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
BDU:2021-03703
Уязвимость функции php_url_parse_ex() интерпретатора языка программирования PHP, позволяющая нарушителю осуществить SSRF-атаку
openSUSE-SU-2021:2637-1
Security update for php7
openSUSE-SU-2021:1130-1
Security update for php7
SUSE-SU-2021:2637-1
Security update for php7
SUSE-SU-2021:2636-1
Security update for php74
RLSA-2022:1935
Moderate: php:7.4 security update
ELSA-2022-1935
ELSA-2022-1935: php:7.4 security update (MODERATE)
ALT-PU-2021-4929
ALT-PU-2021-4929: package `php8.0-soap` update to version 8.0.8-alt1
ALT-PU-2021-2192
ALT-PU-2021-2192: package `php8.0` update to version 8.0.8-alt1
ALT-PU-2021-2180
ALT-PU-2021-2180: package `php7` update to version 7.4.21-alt1
ROS-20220826-01
Множественные уязвимости PHP
SUSE-SU-2022:4069-1
Security update for php7
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2021-21705 In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision. | CVSS3: 5.3 | 2% Низкий | около 5 лет назад | |
CVE-2021-21705 In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision. | CVSS3: 5.3 | 2% Низкий | больше 5 лет назад | |
CVE-2021-21705 In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision. | CVSS3: 5.3 | 2% Низкий | около 5 лет назад | |
CVE-2021-21705 Incorrect URL validation in FILTER_VALIDATE_URL | CVSS3: 4.3 | 2% Низкий | около 1 года назад | |
CVE-2021-21705 In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below ... | CVSS3: 5.3 | 2% Низкий | около 5 лет назад | |
openSUSE-SU-2021:2575-1 Security update for php7 | 2% Низкий | больше 5 лет назад | ||
SUSE-SU-2021:2564-1 Security update for php72 | 2% Низкий | больше 5 лет назад | ||
GHSA-rxcr-7xjm-f9c9 In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision. | CVSS3: 5.3 | 2% Низкий | больше 4 лет назад | |
BDU:2021-03703 Уязвимость функции php_url_parse_ex() интерпретатора языка программирования PHP, позволяющая нарушителю осуществить SSRF-атаку | CVSS3: 5.3 | 2% Низкий | больше 5 лет назад | |
openSUSE-SU-2021:2637-1 Security update for php7 | больше 5 лет назад | |||
openSUSE-SU-2021:1130-1 Security update for php7 | около 5 лет назад | |||
SUSE-SU-2021:2637-1 Security update for php7 | больше 5 лет назад | |||
SUSE-SU-2021:2636-1 Security update for php74 | больше 5 лет назад | |||
RLSA-2022:1935 Moderate: php:7.4 security update | больше 4 лет назад | |||
ELSA-2022-1935 ELSA-2022-1935: php:7.4 security update (MODERATE) | больше 4 лет назад | |||
ALT-PU-2021-4929 ALT-PU-2021-4929: package `php8.0-soap` update to version 8.0.8-alt1 | CVSS3: 5.9 | больше 5 лет назад | ||
ALT-PU-2021-2192 ALT-PU-2021-2192: package `php8.0` update to version 8.0.8-alt1 | CVSS3: 5.9 | больше 5 лет назад | ||
ALT-PU-2021-2180 ALT-PU-2021-2180: package `php7` update to version 7.4.21-alt1 | CVSS3: 5.9 | больше 5 лет назад | ||
ROS-20220826-01 Множественные уязвимости PHP | около 4 лет назад | |||
SUSE-SU-2022:4069-1 Security update for php7 | почти 4 года назад |
Уязвимостей на страницу