Поиск уязвимостей
Количество 12
Количество 12
CVE-2025-5889
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
CVE-2025-5889
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
CVE-2025-5889
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
CVE-2025-5889
juliangruber brace-expansion index.js expand redos
CVE-2025-5889
A vulnerability was found in juliangruber brace-expansion up to 1.1.11 ...
GHSA-v6h2-p8h4-qcjw
brace-expansion Regular Expression Denial of Service vulnerability
BDU:2026-01715
Уязвимость функции expand() библиотеки juliangruber/brace-expansion программной платформы Node.js, позволяющая нарушителю вызвать отказ в обслуживании
openSUSE-SU-2026:20998-1
Security update for tree-sitter-ruby
ROS-20260327-80-0003
Уязвимость nodejs22
ROS-20260327-73-0003
Уязвимость nodejs
ALT-PU-2026-17292
ALT-PU-2026-17292: package `npm` update to version 8.19.3-alt3
SUSE-SU-2025:3744-1
Security update for aws-cli, local-npm-registry, python-boto3, python-botocore, python-coverage, python-flaky, python-pluggy, python-pytest, python-pytest-cov, python-pytest-html, python-pytest-metadata, python-pytest-mock
Уязвимостей на страницу
Уязвимость | CVSS | EPSS | Опубликовано | |
|---|---|---|---|---|
CVE-2025-5889 A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component. | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
CVE-2025-5889 A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component. | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
CVE-2025-5889 A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component. | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
CVE-2025-5889 juliangruber brace-expansion index.js expand redos | CVSS3: 3.1 | 1% Низкий | около 1 года назад | |
CVE-2025-5889 A vulnerability was found in juliangruber brace-expansion up to 1.1.11 ... | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
GHSA-v6h2-p8h4-qcjw brace-expansion Regular Expression Denial of Service vulnerability | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
BDU:2026-01715 Уязвимость функции expand() библиотеки juliangruber/brace-expansion программной платформы Node.js, позволяющая нарушителю вызвать отказ в обслуживании | CVSS3: 3.1 | 1% Низкий | больше 1 года назад | |
openSUSE-SU-2026:20998-1 Security update for tree-sitter-ruby | 5 месяцев назад | |||
ROS-20260327-80-0003 Уязвимость nodejs22 | CVSS3: 3.1 | 1% Низкий | 8 месяцев назад | |
ROS-20260327-73-0003 Уязвимость nodejs | CVSS3: 3.1 | 1% Низкий | 8 месяцев назад | |
ALT-PU-2026-17292 ALT-PU-2026-17292: package `npm` update to version 8.19.3-alt3 | CVSS3: 7.5 | около 1 месяца назад | ||
SUSE-SU-2025:3744-1 Security update for aws-cli, local-npm-registry, python-boto3, python-botocore, python-coverage, python-flaky, python-pluggy, python-pytest, python-pytest-cov, python-pytest-html, python-pytest-metadata, python-pytest-mock | около 1 года назад |
Уязвимостей на страницу