Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

altlinux логотип

ALT-PU-2020-1240

Высокий

ALT-PU-2020-1240: package mariadb update to version 10.4.12-alt1

Источник
errata.altlinux.org
Дата публикации
16.02.2020
Дата обновления
16.02.2020
Устраненные уязвимости
4

ALT Linux branch p11
ALT Container
ALT Education
ALT Workstation
ALT Workstation K
ALT Server
ALT Virtualization PVE Edition
ALT Linux branch p10
ALT Server
ALT Virtualization Server
ALT Workstation
ALT Workstation K
ALT Education
Simply Linux
Starterkit
ALT Container

Описание

This update upgrades mariadb to version 10.4.12-alt1.

Устраненные уязвимости4

Связанные уязвимости

CVSS3: 7.8
ubuntu
почти 7 лет назад

mysql_install_db in MariaDB 10.4.7 through 10.4.11 allows privilege escalation from the mysql user account to root because chown and chmod are performed unsafely, as demonstrated by a symlink attack on a chmod 04755 of auth_pam_tool_dir/auth_pam_tool. NOTE: this does not affect the Oracle MySQL product, which implements mysql_install_db differently.

CVSS3: 7.8
redhat
почти 7 лет назад

mysql_install_db in MariaDB 10.4.7 through 10.4.11 allows privilege escalation from the mysql user account to root because chown and chmod are performed unsafely, as demonstrated by a symlink attack on a chmod 04755 of auth_pam_tool_dir/auth_pam_tool. NOTE: this does not affect the Oracle MySQL product, which implements mysql_install_db differently.

CVSS3: 7.8
nvd
почти 7 лет назад

mysql_install_db in MariaDB 10.4.7 through 10.4.11 allows privilege escalation from the mysql user account to root because chown and chmod are performed unsafely, as demonstrated by a symlink attack on a chmod 04755 of auth_pam_tool_dir/auth_pam_tool. NOTE: this does not affect the Oracle MySQL product, which implements mysql_install_db differently.

CVSS3: 7.8
debian
почти 7 лет назад

mysql_install_db in MariaDB 10.4.7 through 10.4.11 allows privilege es ...

CVSS3: 5.9
ubuntu
почти 7 лет назад

Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.46 and prior, 5.7.28 and prior and 8.0.18 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Client. CVSS 3.0 Base Score 5.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H).