Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

altlinux логотип

ALT-PU-2022-1331

Критический

ALT-PU-2022-1331: package php8.0 update to version 8.0.16-alt1

Источник
errata.altlinux.org
Дата публикации
19.02.2022
Дата обновления
19.02.2022
Устраненные уязвимости
2

ALT Linux branch p11
ALT Container
ALT Education
ALT Workstation
ALT Workstation K
ALT Server
ALT Virtualization PVE Edition

Описание

This update upgrades php8.0 to version 8.0.16-alt1.

Устраненные уязвимости2

Связанные уязвимости

CVSS3: 9.8
ubuntu
больше 4 лет назад

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

CVSS3: 9.8
redhat
больше 4 лет назад

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

CVSS3: 9.8
nvd
больше 4 лет назад

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

CVSS3: 8.2
msrc
около 1 года назад

UAF due to php_filter_float() failing

CVSS3: 9.8
debian
больше 4 лет назад

In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x belo ...