Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

altlinux логотип

ALT-PU-2025-6991

Низкий

ALT-PU-2025-6991: package postgresql17 update to version 17.5-alt0.p10.1

Источник
errata.altlinux.org
Дата публикации
04.06.2025
Дата обновления
04.06.2025
Устраненные уязвимости
2

ALT Linux branch p10
ALT Server
ALT Virtualization Server
ALT Workstation
ALT Workstation K
ALT Education
Simply Linux
Starterkit
ALT Container

Описание

This update upgrades postgresql17 to version 17.5-alt0.p10.1.

Устраненные уязвимости2

Связанные уязвимости

CVSS3: 5.9
ubuntu
больше 1 года назад

Buffer over-read in PostgreSQL GB18030 encoding validation allows a database input provider to achieve temporary denial of service on platforms where a 1-byte over-read can elicit process termination. This affects the database server and also libpq. Versions before PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 are affected.

CVSS3: 5.9
redhat
больше 1 года назад

Buffer over-read in PostgreSQL GB18030 encoding validation allows a database input provider to achieve temporary denial of service on platforms where a 1-byte over-read can elicit process termination. This affects the database server and also libpq. Versions before PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 are affected.

CVSS3: 5.9
nvd
больше 1 года назад

Buffer over-read in PostgreSQL GB18030 encoding validation allows a database input provider to achieve temporary denial of service on platforms where a 1-byte over-read can elicit process termination. This affects the database server and also libpq. Versions before PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 are affected.

CVSS3: 5.9
msrc
больше 1 года назад

PostgreSQL GB18030 encoding validation can read one byte past end of allocation for text that fails validation

CVSS3: 5.9
debian
больше 1 года назад

Buffer over-read in PostgreSQL GB18030 encoding validation allows a da ...