Описание
Apache Tomcat has a Missing Critical Step in Authentication vulnerability
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without providing the correct password.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Ссылки
- https://nvd.nist.gov/vuln/detail/CVE-2026-55957
- https://github.com/apache/tomcat/commit/0cd21c0393b8811af22daddbba7b4e7328e2d79e
- https://github.com/apache/tomcat/commit/c32bbd37ea9ee0aaab848af4ee1c9a76e84240ea
- https://github.com/apache/tomcat/commit/fd96ab415631eea44636c94f911dd38427070ef9
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh
- https://tomcat.apache.org/security-10.html
- https://tomcat.apache.org/security-11.html
- https://tomcat.apache.org/security-9.html
- http://www.openwall.com/lists/oss-security/2026/06/29/26
Пакеты
org.apache.tomcat.embed:tomcat-embed-core
>= 11.0.0-M1, < 11.0.5
11.0.5
org.apache.tomcat.embed:tomcat-embed-core
>= 10.1.0-M1, < 10.1.37
10.1.37
org.apache.tomcat.embed:tomcat-embed-core
>= 9.0.0.M1, < 9.0.101
9.0.101
org.apache.tomcat.embed:tomcat-embed-core
>= 8.5.0, <= 8.5.100
Отсутствует
org.apache.tomcat.embed:tomcat-embed-core
<= 7.0.109
Отсутствует
org.apache.tomcat:tomcat
>= 11.0.0-M1, < 11.0.5
11.0.5
org.apache.tomcat:tomcat
>= 10.1.0-M1, < 10.1.37
10.1.37
org.apache.tomcat:tomcat
>= 9.0.0.M1, < 9.0.101
9.0.101
org.apache.tomcat:tomcat
>= 8.5.0, <= 8.5.100
Отсутствует
org.apache.tomcat:tomcat
<= 7.0.109
Отсутствует
org.apache.tomcat:tomcat-catalina
>= 11.0.0-M1, < 11.0.5
11.0.5
org.apache.tomcat:tomcat-catalina
>= 10.1.0-M1, < 10.1.37
10.1.37
org.apache.tomcat:tomcat-catalina
>= 9.0.0.M1, < 9.0.101
9.0.101
org.apache.tomcat:tomcat-catalina
>= 8.5.0, <= 8.5.100
Отсутствует
org.apache.tomcat:tomcat-catalina
<= 7.0.109
Отсутствует
Связанные уязвимости
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Missing Critical Step in Authentication vulnerability in Apache Tomcat ...