Описание
ELSA-2026-85814: postgresql:18 security update (IMPORTANT)
pgaudit [18.0-1]
- Update to 18.0
- Initial import for postgresql18
pg_repack [1.5.3-1]
- Update to 1.5.3
- Initial import for postgresql18
[1.5.1-1]
- Update to v1.5.1
[1.4.8-2]
- Add new build dependencies to fix build with lz4 enabled
- Related: RHEL-47604
pgvector [0.8.7-1]
- Update to 0.8.7
- Fixes CVE-2026-103484 (out-of-bounds write during IVFFlat index build, which could lead to arbitrary code execution)
[0.8.1-1]
- Update to 0.8.1
- Initial import for postgresql18
[0.6.2-2]
- Enable Portable build
- Resolves: RHEL-84405
postgis [3.6.1-4]
- Fix backport regression in ST_FromFlatGeobufToTable (CVE-2026-73515 patch)
[3.6.1-3]
- Backported a patch to fix a security vulnerability (CVE-2026-73515)
[3.6.1-1]
- Update to 3.6.1
- Initial import for postgresql18
- Avoid perl(Pg) dependency on RHEL
[3.5.3-3]
- Rebuild (gdal)
[3.5.3-2]
[3.5.3-1]
- Update to 3.5.3
[3.5.2-2]
- Rebuild (SFCGAL)
[3.5.2-1]
- Update to 3.5.2
[3.5.1-2]
[3.5.1-1]
- Update to 3.5.1
postgres-decoderbufs [3.3.1-1.Final]
- Update to 3.3.1.Final
- Initial import for postgresql18
postgresql [18.6-1]
- Update to 18.6
[18.4-1]
- Update to 18.4
- Fix CVE-2026-6478
[18.3-2]
- Enable pltcl subpackage
[18.3-1]
- Update to 18.3
- Fixes: CVE-2026-2004 CVE-2026-2005 CVE-2026-2006 CVE-2026-2007
[18.1-1]
- Update to 18.1
[18.0-1]
- Initial import of 18.0
Обновленные пакеты
Oracle Linux 9
Oracle Linux aarch64
Module postgresql:18 is enabled
pg_repack
1.5.3-1.module+el9.8.0+90922+3defa420
pgaudit
18.0-1.module+el9.8.0+90922+3defa420
pgvector
0.8.7-1.module+el9.8.0+91071+3612b603
postgis
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-client
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-docs
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-upgrade
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-utils
3.6.1-4.module+el9.8.0+91071+3612b603
postgres-decoderbufs
3.3.1-1.Final.module+el9.8.0+90922+3defa420
postgresql
18.6-1.module+el9.8.0+91071+3612b603
postgresql-contrib
18.6-1.module+el9.8.0+91071+3612b603
postgresql-docs
18.6-1.module+el9.8.0+91071+3612b603
postgresql-plperl
18.6-1.module+el9.8.0+91071+3612b603
postgresql-plpython3
18.6-1.module+el9.8.0+91071+3612b603
postgresql-pltcl
18.6-1.module+el9.8.0+91071+3612b603
postgresql-private-devel
18.6-1.module+el9.8.0+91071+3612b603
postgresql-private-libs
18.6-1.module+el9.8.0+91071+3612b603
postgresql-server
18.6-1.module+el9.8.0+91071+3612b603
postgresql-server-devel
18.6-1.module+el9.8.0+91071+3612b603
postgresql-static
18.6-1.module+el9.8.0+91071+3612b603
postgresql-test
18.6-1.module+el9.8.0+91071+3612b603
postgresql-test-rpm-macros
18.6-1.module+el9.8.0+91071+3612b603
postgresql-upgrade
18.6-1.module+el9.8.0+91071+3612b603
postgresql-upgrade-devel
18.6-1.module+el9.8.0+91071+3612b603
Oracle Linux x86_64
Module postgresql:18 is enabled
pg_repack
1.5.3-1.module+el9.8.0+90922+3defa420
pgaudit
18.0-1.module+el9.8.0+90922+3defa420
pgvector
0.8.7-1.module+el9.8.0+91071+3612b603
postgis
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-client
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-docs
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-upgrade
3.6.1-4.module+el9.8.0+91071+3612b603
postgis-utils
3.6.1-4.module+el9.8.0+91071+3612b603
postgres-decoderbufs
3.3.1-1.Final.module+el9.8.0+90922+3defa420
postgresql
18.6-1.module+el9.8.0+91071+3612b603
postgresql-contrib
18.6-1.module+el9.8.0+91071+3612b603
postgresql-docs
18.6-1.module+el9.8.0+91071+3612b603
postgresql-plperl
18.6-1.module+el9.8.0+91071+3612b603
postgresql-plpython3
18.6-1.module+el9.8.0+91071+3612b603
postgresql-pltcl
18.6-1.module+el9.8.0+91071+3612b603
postgresql-private-devel
18.6-1.module+el9.8.0+91071+3612b603
postgresql-private-libs
18.6-1.module+el9.8.0+91071+3612b603
postgresql-server
18.6-1.module+el9.8.0+91071+3612b603
postgresql-server-devel
18.6-1.module+el9.8.0+91071+3612b603
postgresql-static
18.6-1.module+el9.8.0+91071+3612b603
postgresql-test
18.6-1.module+el9.8.0+91071+3612b603
postgresql-test-rpm-macros
18.6-1.module+el9.8.0+91071+3612b603
postgresql-upgrade
18.6-1.module+el9.8.0+91071+3612b603
postgresql-upgrade-devel
18.6-1.module+el9.8.0+91071+3612b603
Связанные CVE
Связанные уязвимости
IVFFlat index build in pgvector before 0.8.7 allows a database user to write data out-of-bounds, which can lead to arbitrary code execution.
IVFFlat index build in pgvector before 0.8.7 allows a database user to write data out-of-bounds, which can lead to arbitrary code execution.
IVFFlat index build in pgvector before 0.8.7 allows a database user to write data out-of-bounds, which can lead to arbitrary code execution.
IVFFlat index build in pgvector before 0.8.7 allows a database user to ...