Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

altlinux логотип

ALT-PU-2014-1425

Критический

ALT-PU-2014-1425: package ansible update to version 1.5.4-alt1

Источник
errata.altlinux.org
Дата публикации
02.04.2014
Дата обновления
04.02.2026
Устраненные уязвимости
2

ALT Linux branch p11
ALT Container
ALT Education
ALT Workstation
ALT Workstation K
ALT Server
ALT Virtualization PVE Edition
ALT Linux branch p10
ALT Server
ALT Virtualization Server
ALT Workstation
ALT Workstation K
ALT Education
Simply Linux
Starterkit
ALT Container

Описание

This update upgrades ansible to version 1.5.4-alt1.

Устраненные уязвимости2

Связанные уязвимости

CVSS3: 7.5
ubuntu
почти 7 лет назад

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

CVSS3: 7.5
nvd
почти 7 лет назад

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

CVSS3: 7.5
debian
почти 7 лет назад

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

CVSS3: 9.8
ubuntu
больше 6 лет назад

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

CVSS3: 9.8
redhat
больше 12 лет назад

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.