ALT-PU-2019-2384: package postgresql9.4 update to version 9.4.24-alt1
Описание
This update upgrades postgresql9.4 to version 9.4.24-alt1.
Устраненные уязвимости5
Связанные уязвимости
ALT-PU-2019-2387: package `postgresql10` update to version 10.10-alt1
ALT-PU-2019-2386: package `postgresql9.6` update to version 9.6.15-alt1
ALT-PU-2019-2385: package `postgresql9.5` update to version 9.5.19-alt1
ALT-PU-2019-2383: package `postgresql11` update to version 11.5-alt1
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function.