Логотип exploitDog
Консоль
Логотип exploitDog

exploitDog

altlinux логотип

ALT-PU-2019-2386

Критический

ALT-PU-2019-2386: package postgresql9.6 update to version 9.6.15-alt1

Источник
errata.altlinux.org
Дата публикации
07.08.2019
Дата обновления
04.02.2026
Устраненные уязвимости
5

ALT Linux branch p11
ALT Container
ALT Education
ALT Workstation
ALT Workstation K
ALT Server
ALT Virtualization PVE Edition
ALT Linux branch p10
ALT Server
ALT Virtualization Server
ALT Workstation
ALT Workstation K
ALT Education
Simply Linux
Starterkit
ALT Container

Описание

This update upgrades postgresql9.6 to version 9.6.15-alt1.

Устраненные уязвимости5

Связанные уязвимости

CVSS3: 9.8
altlinux
больше 7 лет назад

ALT-PU-2019-2387: package `postgresql10` update to version 10.10-alt1

CVSS3: 9.8
altlinux
больше 7 лет назад

ALT-PU-2019-2385: package `postgresql9.5` update to version 9.5.19-alt1

CVSS3: 9.8
altlinux
больше 7 лет назад

ALT-PU-2019-2384: package `postgresql9.4` update to version 9.4.24-alt1

CVSS3: 9.8
altlinux
больше 7 лет назад

ALT-PU-2019-2383: package `postgresql11` update to version 11.5-alt1

CVSS3: 8.8
ubuntu
около 7 лет назад

A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function.