Описание
Important: httpd security update
The httpd packages provide the Apache HTTP Server, a powerful, efficient, and extensible web server.
Security Fix(es):
-
httpd: httpd: HTTP response smuggling via crafted Transfer-Encoding response in mod_proxy_uwsgi (CVE-2026-63718)
-
httpd: httpd: Denial of Service via integer overflow in mod_dav_fs (CVE-2026-93546)
-
httpd: httpd: Authentication state corruption via concurrent Digest authentication requests (CVE-2026-73637)
-
httpd: httpd: unauthorized connection to arbitrary hosts via crafted FTP PASV response (CVE-2026-63045)
-
httpd: httpd: Arbitrary code execution via oversized Host header in mod_vhost_alias (CVE-2026-63292)
-
httpd: httpd: mod_heartmonitor: Denial of Service via NULL pointer dereference (CVE-2026-46729)
-
httpd: httpd: Authentication bypass via credential replay in mod_auth_digest (CVE-2026-73636)
-
httpd: httpd: Denial of Service via charset conversion failure in mod_xml2enc (CVE-2026-63686)
-
httpd: httpd: Denial of service via forged Authorization headers in mod_auth_digest (CVE-2026-48005)
-
httpd: httpd: Denial of Service via mod_rewrite lookahead (CVE-2026-56154)
-
httpd: httpd: Denial of Service via heap-based buffer overflow in mod_charset_lite (CVE-2026-56153)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Затронутые продукты
Rocky Linux 9
Ссылки на источники
Исправления
- Red Hat - 2544781
- Red Hat - 2544798
- Red Hat - 2544814
- Red Hat - 2544823
- Red Hat - 2544832
- Red Hat - 2544835
- Red Hat - 2544849
- Red Hat - 2544852
- Red Hat - 2544861
- Red Hat - 2544869
- Red Hat - 2544885
Связанные уязвимости
ALT-PU-2026-17325: package `apache2` update to version 2.4.69-alt1
NULL Pointer Dereference vulnerability in Apache HTTP Servers mod_heartmonitor over unicast listener. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
NULL Pointer Dereference vulnerability in Apache HTTP Servers mod_heartmonitor over unicast listener. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
NULL Pointer Dereference vulnerability in Apache HTTP Servers mod_heartmonitor over unicast listener. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.